Downloads for earlier Vectir PC Versions

Version 3.4

Important! Version 3.4 is not the latest version of the Vectir PC software and should only be installed if you are running Windows XP SP2 or earlier or are unable to install version 4.0 of the Microsoft .net framework.

Vectir Free Server v3.4

Vectir Full Server v3.4